Course in ANSYS
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Example — Cantilever beam
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Objective: E = 210000N/mm?
Compute the maximum deflection and locate v=03
point of maximum deflection L =100mm
Tasks: a=10mm
How should this be modelled? b =10mm
Compare results with results obtained F = 100N
from beam theory?
Topics:

Element type, Real constants, modeling,
Plot results, output graphics
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Example - title

Utility Menu > File > Change Jobname

/jobname, Example0300 e

I\Change Jobname I

GUI
Command line entry

x| Enter: Example0300
|

[/FILNAM] Enter new jobname Ihlg P
Mews log and error files? I Mo
K Cancel | Help

Utility Menu > File > Change Title
[title, Cantilever beam

I Change Title I

Enter: Cantilever beam

[/TITLE] Enter new title [l .

OK,

Cancel | Help |
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Example - Areas

Preprocessor > Modeling > Create > Areas > Rectangle > By Dimensions
Create an area given by X=(0,100) and Y=(0,10)

ANGYS Main Manu @

references
freprocessor
4 Clement Type
1 Real Constants
7 Materlal Props
31 Sections
=1 ioedeeing
B Create
[ Keypoints
@ Lines
B Areas
i Arbitrary
1 Rectanghe
A By 2 Cormers 0K Apply

[RECTNG] Create Rectangle by Dimensions
¥1,%2 ¥-coordinates

¥1,%2 Y-coordinates

I\ Create Rectangle by Dimensions

Cancel |

)
)

LI

L

Help |

A By Centr & Corme
2y omensions]

& Circle

i Palynon
A area Fillet
& Volumes
B Nodes
E Clements.
B Contact Pair
8 Piping Models.
B Circuit
B racetrock Coil
B Tramsducers
E Operate
& Move / Modify
& Copy
B Reflect
& Chck Geom
[ Delete
1 cycle sector 4

] | —

— Press OK

(also numbered automatically)

Note: Keypoints (4 kp’s) and lines
(4 lines) are automatically generated
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Enter O or
leave empty

— Enter 100

|

| EnterOor

Enter 10

leave empty




Example - Area

ANSYS

ey 11
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Example - Operate

Preprocessor > Modeling > Operate > Extrude > Areas > Along Normal
Create a volume by extruding the area 10 along its surface normal vector

aEsSwnme @ Extrude Are:

B Profervmes A P
= * Pick o 3
B Clariont e i M Extrude Area along Normal x|
E ;Z::;T;:;‘: @ single " Box [WOFFST] Extrude Area along Marmal
R Sectiones €iPolygon (7 pirole MAREA Area to be extruded 1
O Modeling " Loop
B Lreate DIST Length of extrusion !
Fl Opeerattis =
B Cxtrude Cow_m o KINC  Keypoint increment
E Elem Ext Upts s = 4
= Minimam = 1
R along Normal @ =
By ®¥Z Dkt i oK Apply Cancel | Help |
# About Auds e
R along Lines % List of Items
B Lines
@ Keypolnts " Min, Max, Inc
A extend Line
[T | —
@ Scale
& Gale rom Items | Enter 10
& Move [/ Modify | R PreSS OK
o
& Pt

E E'E‘f:‘k:enm Beser Cancal
B Cyclic Seclor
& Genl plane strn il 4Ll Help

B update teom I —
B Mushing Note: Bottom left corner of ANSYS GUI
# Checking Ctris
& Numidwering Clris [ TvorFSTT Pick or enter the arsa tn he extruded
@ chhlye l\‘!ndel d

: Example0300 6
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Example — Mouse rotate

Rotate by
holding the
Ctrl key
down while
using the
right hand
mouse
button
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Example — Element Type

Preprocessor > Element Type > Add/Edit/Delete

Element Types X
g M\Library of Element Types x|
[NONE DEFINED Library of Element Types Structural Mass - Bnode 63 -
Link Brick 8node 45
Beam Snode 185
Pipe
Rigid 20node 95 hd

- 20node 186

Element type reference number

Ok Apply | Cancel | Help |

add.. | —— ] Press Add
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Example - Element Type

Preprocessor > Element Type > Add/Edit/Delete
|

Defined Element Types:

VS AYSOLID186 element type options I |

Options for SOLID1EEG, Element Type Ref. No. 1

Elerment technology k2 W
Element output coordinates K4 W

Elernent formulation K& W
User defined initial stress K10 W

Ol Cancel | Help |.7
sse..| coteone. fo — Press Options
N [ ] Press Help to learn more about the
element.
Example0300 9

Example — Real Constants

No Real Constants are necessary for pure 3D solid models!
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Example - Material Properties

Preprocessor > Material Props > Material Models

Double Click
MDefine Material Model Behavior I [m] ] .
Waterial it Help to step in the
[ Material Models Defined ————— | [~ Material Models Availzble matenal tree
€ Material Mode| Mumber 1 | @ Structral =
@ Linear
& Elastic
-y o oo
e crn N
ERRUEELE] | inear Isotropic Properties for Material N x|
Monlinear
@ Density Linear Isotropic Material Properties for Material Number 1
Thermal Expansior
& Damping

Ti
= @ Friction Coefficient
- | Temperatures
e | e At im] (it
4 | > |_ 4| EX

PRXY
Add Temperature | Delete Temperature | Graph
oK. | Cancel | Help |
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Example - Material Properties

Preprocessor > Material Props > Material Models

: Click here
Linear Isotropic Properties for Material Nui x| Enter- C|
Modulus of elasticity to Close
Linear Isotropic Material Properties for Material Wumber 1
Enter:
. , .
L Poisson’s ratio
Temperatures
EX 210000
PRXY E| Dofine Material Model Behavior -|0| x|
Material Edit Help
[ Material Models Defined ———— | [ Material Models Available
8 Material Model Murmber 1 = 8 Structural =
Add Temperature | Delete Temperature | @ Linear lsotropic B Linear
8 Elastic
Jt Ok Canc S
— @ Orthotropic
@ snisotropic
Monlinear
@ Density
Thermal Expansion Coef
€ Darping
Press OK - — #® Friction Coefficient
= (2@ | oo M ~toris | Cedicne hd
. - BB I>|_|

Example0300 12




Example - Meshing

Preprocessor > Meshing > Size Cntrls > ManualSize > Lines > Picked Lines

Select/Pick
Lines to
specify
mesh size
for

Element Size

% piok " Unpick
% Single  Box

" Polygen (" girele
 Loop

Count. = 0
Maximum =

Minimm =

Lins No. =

& List of Trems

" Min, Max, Inc

oy
Teset Cancel
Pick All Help

Select the indicated lines

Example0300

= Press OK when finish with selection

13

Example - Meshing

Preprocessor > Meshing > Size Cntrls > ManualSize > Lines > Picked Lines

Element Sizes on Picked Lines

[LESIZE] Element sizes on picked lines
SIZE Element edge length
NDIV  No. of element divisions

(NDIV is used only if SIZE is blank or zero)

KYNDIV SIZE,NDIV can be changed ¥ Yes

SPACE Spacing ratio

il

%]

ANGSIZ Division arc (degrees)

( use ANGSIZ only if number of divisions (NDIV) and
element edge length (SIZE) are blank or zero)

||

Clear attached areas and volumes " No

OK Apply | Cancel I

Help |

’_1

Enter 2 —

Press OK when finish with selection

Example0300

14




ANSYS Main Menu

Example - Meshing

Preprocessor > Meshing > Mesh > Volumes > Mapped > 4 or 6 sided

ANSYS Main Menu

ANSYS Main Menu

]

E Preferences

[ Size Cnirls
& Mesher Opts
B Concatenate
& mesh

B Mapped
Frea
B Yohame Swer
[ Tet Mesh Fr
B Interface Me
B Maodily Mesh

rehive Mol
H—
LOTRAN Sat Lip

B Preferences
B Proprocessar
& Element Type
& Real Constants
(@ material Props
@ Sections
= Mol
Meshing
Mash Attributes
meshTool
[ Size Cnirls
& Mesher Opts
B Concatenate
& mesh

A4 ta b sided
& Concatenati

& In ace Mash
@ Modify Mesh
@ Check Mesh
B Chear
8 Chwecking Ctris
Nasmbring Ctris
& Archive Model
@ Coupling / Ceqgn

E Preferences

B Proprocessar
& Element Type
& Real Constants
(@ material Props

@ Sections

= Mol

esshing
 Mash Attributes
2 meshTool

[ Size Cnirls
& Mesher Opts
B Concatenate
& mesh

@ Concatenate

@ Del

A Free

& Interface Mesh
@ Modify Mesh
@ Check Mesh
B Chear
8 Chwecking Ctris
Nasmbring Ctris
& Archive Model
@ Coupling / Ceqgn

Mesh Volurr

* Pick @ thnpick

{* single (" Box

' Polygen  Circle
€ Loop,

Count = 0
Maximum = 1
Minimum = 1

Volu No. =

@ List of Items

 Min, Max, Inc

——

Reset Cancel

Pick All

Help

Select individual
volumes to be
meshed

NB: It is often
necessary to “Clear”
the model for
example if Element
Type or model
geometry is to be
changed

Select all volumes
defined to be meshed

@ Phrysics S FLOTRAN ety | S FLOTRAN ety IIA % ‘
Example0300 15
Example — 3D Mesh
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Example — Analysis Type

File > Write DB log file
Enter “example0300.Igw”

Write Database Log
\wiite Database Logto

Directories:

o Sadministrator

l d =1 = Cancel
R e
(£ Cookies
. gl
List Files of Type: Dives:

Solution > Analysis Type > New Analysis

[ANTYPE] Type of analysis

OK

Cancel

[Dasbane Loarian] =] [

= Network
=

['white non-essential cmds as comments

£ Modal

" Harmonic

£ Transient

£ Spectrum

£~ Eigen Buckling
~ Substructuring

Help |

Example0300 17

Example — Define Loads

Solution > Define Loads > Apply > Structural > Displacement > On Areas

Apply UROT o

 pick @——Tmgick

* Single (" Bo

O Polygen (" cifele

" Loop

Count = 0
Maximum

Minimum

W
o

Area No_

Select Area
A6 or the left
end area

Select All DOF to fix/clamp the beam

I Apply U,ROT on Areas |
[Da] apply Displacements (J,ROT) on Areas
Lab2  DOFs to be constrained

L

L
Uz

* List of Items

" Min, Max, Inc

0E @ vy |
Reset Cancel
Pick All Help

All DOF
Constant value -

—

Cancel |

Apply as
If Constant value then:
VALUE Displacement valus

o g | apoly | bep_|

— Press OK

Example0300 18




Example — Define Loads

Solution > Define Loads > Apply > Structural > Force/Moment > On Nodes
Note: If the model is remeshed all loads will be deleted with the element nodes

* pick @—F—tmpreyr

¥ Single (" Box

" Polygen (" girele
C Loop.

Select indicated element node

Count
Maximum

Mindmum

W
B
S
=

Node Ho.

i List of Trems

" Min, Max, Inc

Reset Cancel
Pick All Help

===

Press OK

Example0300 19

Example — Define Loads

Solution > Define Loads > Apply > Structural > Force/Moment > On Nodes

Change to FY

T\ Apply F/M on Nodes x|
[F]1 &pply ForceMoment on Nodes
Lab  Direction of force/mom m

Apply a5

If Constant value then:
WALUE  Force/moment value

oK @ | Apply Cancel | I Help |
Press OK to finish Enter -100
Example0300 20
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Example - Save

Display of Analysis model

ANSYS Toolbar

‘ SAVE_DBl RESUM_DB |ﬂ| POWRGRF’H' E-CAEl Save the model

[

Example0300 21

Example - Solve

Solution > Solve > Current LS

ANSYS Main Menu )]

E Preferences

Preprocessor

= Selution
Analysis Type

Define Loads
Load Step Opts Sohre Ci nt Load Step J x|
& [SOLVE] Begin Solution of Current Load Step

re;
[ Partial Solu Review the summary information in the lister windowr (entitled

B Adaptive Mesh "/STATUS Command"), then press OK to start the solution.
FSI Set Up
& ADAMS Connection
E unabridged Menu
& General Postproc
@ TimeHist Postpro
Topological Opt
ROM Tool
Design Opt
Prob Design
Radiation Opt
Run-Time Stats
[ session Editor
E Finish

Cancel Help

Press OK

Example0300 22
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Example - Solve

.}‘J Solution is done!

Press Close

Press here
to Close
x|
File
SOLUTION ODPTIOHNS
PROBLEH DIMENSIONALITY. . . . . o0 o0y u 30
DEGREE FREEDOH. . . . . . uxoouyouz
RHALYSIS TYPE . . . . L L L L STRTIC (STERDN-STATED
LOAD STEP OPTIONS
LOAD STEP MUKBER. . . . . . .. .. .. .... 1
TIHE AT END OF THE LOAD STEP. 1.0000
HUHBER OF SUBSTEPS. . . . . . 1
STEP CHANGE BOUNDARY COMDITIONS . . K
PRINT OUTPUT CONTROLS . .+« o o v v v oo . WHOPRIY Ol
DRTARBASE OUTPUT COMTROLS. . .« o v o v v w ALL OHTH HRITTEN
FOR THE LHST SUBSTEF
Example0300 23

Example - PostProcessing

General Postproc > Plot Results > Deformed Shape

[PLDISP] Plot Deformed Shape
KUND Items to be plotted
= Def shape only

" Def + undeformed @

|

© Def + undef edge

oK Apply Cancel Help

Select “Def+undeformed”
and Press OK

l

Example0300
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Example - PostProcessing

—— Read Maximum displacement: DMX

Example0300
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Example — Comments/Questions

» What did change compared to the Beam
model?

* The “example0300.Igw” can be edited in
“Notepad”

* What are the assumptions in this case?

» Will the shape or the number of elements
affect the solution?

Example0300
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File Select List

Clear & Start New ...
Change Jobname ...
Change Directory ...
Change Title ...

File menu

Plot PlotCirls  WorkPlane Parameters Macro  MenuCirls

Help

Resume Jobname.ch ...

Resume from ...

Save as Jobname.db
Save as ...
Wite DB log file ...

Read Input from ..,
Switch Output to

List
File Operations

ANSYS File Options ...

Import
Expart ...

Report Generatar ...

Exit ...

~—

You can include commands to be
executed when the program starts up in

the start71.ans file.

I Clear Database and Start New

[fCLE&R] Clear database and start new!

Read start.ans after clear?

[e]9

Cancel |

+ Read file
© Do not read file

Help |

Clears (zeros out) the database stored in
memory. Clearing the database has the same

effect as leaving and reentering the ANSYS

program, but does not require you to exit.

Example0300
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