Sensitivity and Optimization Tutorial (Pro Mechanica Wildfire 2.0)
Time: 2 hours and 20 minutes

Source: Pro/Mechanica Structure Wildfire: Elements and Applications (Integrated
mode) YVES Gagnon, M.A.Sc, SDC Publications (Chapter 1).

Objective:

To demonstrate the use of Pro Mechanica in sensitivity and optimization studies.
Overview:

The purpose of an optimization study is to help the designer in optimizing certain design
parameters as a function of known measures, such as Von Mises Stress or maximum
displacement for a specific goal (i.e. Minimize total mass). The software can not do all
the work in the optimization process; this is only a tool the designer uses to get to the
final objective, so that the Designer’s knowledge plays a very important roll in any
optimization study.

The optimization study (Pro Mechanica) we are going to perform is divided into main
phases:

1. Design Phase I: In this part a static analysis is created and later is combined with
local and global sensitivity studies in Pro Mechanica. In this phase, Pro Engineer
Wildfire 2.0 is used to set the Design parameters.

a. The Main objective of a local sensitivity study is to look at changes of the
measures, Von Mises in most cases, for small variations of each design
parameter (- 1%) independently.

b. The Objective of the global sensitivity study is to look at the variations of
all parameters, within their respective range, into each step of the process
as defined by the user.

2. Design Phase II: Completes the optimization of the part according to your design
objectives (goals). All parameters are optimized concurrently. A goal could be to
minimize the total mass or the total cost of the model



Procedure:
The procedure to carry out the Optimization process is as follows:

1. Create the part in Pro/Engineer

2. Switch to Pro/Mechanica mode and create a shell mid-plane compression
idealization (assign material properties)

3. Create the mesh and boundary conditions (loads and constraints)

4. Run a quick check analysis to know if the model converges to a solution with
respect to a measure (Von Mises Stress)

5. Set up Design parameters for the preliminary design study

6. Run a local sensitivity study and select parameters that have an effect on the
measures predetermined

7. Run a global sensitivity study on selected parameters and find the parameter value
(maximum and minimum) that has the greatest effect on the measure

8. Run an optimization study for the above parameters, setting the starting point of the
study using the findings of point #7 above. Optimize for your design objective(s). The
design objective for this case is to minimize the mass of the plate.



The following figure shows the model that will be used for the study. It’s a simple
plate with two notched cuts located 6 in. from the left end. The loads are applied at
the tip of the right end of the plate, while the left end is constrained (where the
coordinate system is)

Figure 1 (Notched Cantilever Beam)

The Design objectives are to optimize the location and radius of the notch with
respect to the left end of the plate. We will also look at plate thickness and optimize
all three parameters above for the total mass, using the Von Mises stresses as the
measure.



Please, refer to model represented in Figure 1. It is a plate made of Steel, now, we are
going to define the objectives and determine the measure to be studied for the
selected design parameters.

Optimization Measure to be Design Parameters to be optimized
Goal used for
Optimization
Minimize Von Mises Stresses Name Description Initial
Weight of the Value(in)
part Cut_length | Dimension 6
from left
edge to cut
Cut_radius | Notch radius 0.25
Thickness Plate 0.25
Thickness

Before starting the procedures below, create a directory named Opt_Study, using
Microsoft Explorer. Copy the part named Plate_Tutorial to that directory

Note: Integrated Mode in Pro/Mechanica: This mode can be accessed via
Applications-Mechanica-Structure-Model. This mode can be used for structural
modeling of a part/assembly i.e., define all the simulation modeling entities and
prepare the model for finite element analysis.



1. Start up Pro/E Wildfire 2.0

Select Start>All Programs>PTC>Pro/Engineer>Pro/Engineer
This procedure to run the software can be different on every computer
Set up your working directory (File>Set Working directory)

Select your working directory Opt_Study, then click on Accept

2. Open the file Plate_Tutorial

Once open, the following part show up on your screen

PRT_CSYS DEF

Figure 3




3. Modifying Dimension Cosmetics in Pro/E

We have to modify the dimensions cosmetics in Pro/Engineer for ease of recognizing
each optimized design parameter during the process. From the model tree, select
Protrusion id39 (the id number could be different) and click on it with the right
button of the mouse, a pop up menu appears, select edit, the dimensions for the
feature will show up on the screen
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Select the R.25 dimension and click on it with the right button of the mouse, and
select properties, select the Dimension Text Tab

Change the dimension text name to cut_radius

imension Pr

e

Select Ok



Repeat the procedure for the 6.00 inches dimensions and rename it to cut_length as
shown below

| Dimension Prop

Now, change the thickness dimension

Click Ok




4. Switching to Pro/ Mechanica

Select Applications>Mechanica

| & unit Info

Every Pro/ENGINEER and Mechanica model has an associated
principal System of Units.

The principal System of Units for this madel is;

(Integrated Mode)
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&l model data must be consistent with this System of Units,

Press Continue to keep this System of Units, or press Cancel and
. select a different principal System of Units.

I Don't display this message again if model units change

A dialog box appears indicating the units the software will use to perform the analysis

Click on Continue

‘| I” FEM Mode
= Type
* 3D
" 2D Plane Stiess [Thin Plate)

" 2D Plahe Strain (Infinitely Thick)
€ 2D Asisymmetiic

— Geometry -
Heferencels|

‘ﬂ ]‘Not Selected o

/| 7 Coordinate System —

..U Mot Selected

o

A new dialog box appears, select structure and 3D
analysis
Click on Ok

Model Type:- Opens the model type definition dialog form.
Lets the user define the model type. Default model type is
always 3D. If the model type selected should be 2D, user also
has to select the Geometry and the associated coordinate
system.

3D

2D Plane Stress

2D Plane Strain

2D Axisymmetric

If the model is a 2D model, all geometry, loads and
displacements must lie in the xy plane of the Cartesian
coordinate system. For 2D axisymmetric models, all
coordinates must be positive in X in the XY plane.



A new group of buttons (tool bars) appears on the right of your screen (These are the
Pro/Mechanica tool bars)
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Idealizations:- The Following idealizations are available in the Integrated Mode — Shells,
Beams, Masses, Springs. These idealizations should be used whenever possible as they
require less computation time. Another advantage of using these models is that they are
easy to model.

For this exercise we are going to create a compressed shell idealization (the thickness
of the plate permits to do it).

Select Insert>Midsurface
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Menu Mange:r

The following pop up menu appears o MDSUREACES:

Select New

Another pop up selection box appears

Holding down the Control (CTRL) Key select one of the faces of the plate, and then
select the other face

Click on Ok twice



Now, click on Compress

 Shaw
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You should see the yellow color contour of the part on the screen as shown above

Select Done>Done/ Return

S. Assigning Materials properties to the Model

Materials:- This option selects the user define/select the material for the model. There
are many standard materials listed as Materials in Library and the user can assign one of
those standard materials to the part(s) and the user can also preview the properties of the
standard material by clicking on the “Edit” button on the right hand side. User can also

create a material of his/her own choice by clicking on the “New” button on the right hand
side.

The plate is made of standard ASTM A-36 Steel (36 ksi yield strength). Select
Properties>Materials (see next page) and the following window will come up
Select steel from the left column and click on the arrow to move in under the
materials in model column. Click on Assign>Part and select the plate. Click on the
middle mouse button to accept. Click on Close
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6. Creating a Mesh on the Model

We will keep all default shell elements and settings that AutoGEM will create. Select
AutoGEM >Create
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AutoGEM:- This command can be used to review the mesh before running any analysis.
The advantage of using AutoGEM is that if the model fails to create elements after
performing AutoGEM operation, we can identify which portion of the model was
creating the problem. Please note that it is not mandatory to perform AutoGEM before
running an analysis. If AutoGEM is not performed, elements are going to be created
during the running of an analysis.



After selecting create the following Selection Box appears

Click on Create

This confirmation of elements box should
come up

Note that only one triangular and 10

quadrilateral elements have been created

Select Close
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Click on the setup simulation display button on the toolbar
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Use the display setting to shrink all
elements to 10%, Click on Preview
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This is the mesh for the model

Now, unselect shrink elements options in the simulation display dialog box and click
Ok, Click Close on the AutoGEM box

Click Yes to save the mesh :: T




7. Boundary Conditions on the Model

Constraints/Loads:- This menu is used to define loads and constraints for the model.
Please note that the default coordinate system is WCS and the user has the option to
either select a pre-defined coordinate system or define and select a coordinate system on
the fly. It is advisable to “preview” loads before hitting OK button just to make sure
everything is right.

7.1. Loads

The end load has 500 Lbs in both the X and Y directions. We will set this load as end
edge load.

Select Insert>Force/Moment Load
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The following Dialog box appears:

Change the name of the constraint set,
select Edge/Curve, and use the following
force components: 500 and -500 in the X
and Y direction

Select the arrow on the references part of
the Force/Moment dialog box and select
the right vertical edge from the model

Click Preview to see how the constraints
are applied on the model

Click Ok
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Your model should look like the following graphic

Applied forces diagram




7.2 Constraints

The plate is a cantilever beam with the left end being fixed. To apply the end
constraints, select Insert>Displacement Constraints
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8. Static Analysis

We are going to create a quick check no convergence analysis named Static_1 to
make sure that we can get to a solution. Results are not important at this point, we just
want to make sure that the model can get to a solution

Select Analysis>Mechanica Analyses/ Studies
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Select Ok
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Click Close

Now, we are going to create a Multi Pass Adaptive convergence

Edit the quick check analysis (right mouse click on it and select edit)



Enter the information as seen in the box below

I Static Analysis Definition
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Select Ok, then run the analysis. Answer Yes to activate the error detection. Click on
Display study status to see if we can get a solution



The solution converges
within 10% in 3 passes
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8.1 Results of Static Analysis

Create a Von Mises

x|

Fill out the result window as follows:

-t B Result W'indu Dg;ﬁnl:ian
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stress definition sheet as follows;

l Click on the review result button
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Check out the Deformed, animate and continuous Tone boxes

# Result Window Definition

Click Ok and Show



Static Analysis Von Mises Stress Results

Select File>Exit Results>NO



As we can see in the Von Mises Stress Analysis, the max Stress is 1.82 x10* Psi, the
material has an Sy =3.6 x10*, as it is a static analysis we can use a security factor of
1.5, so that our maximum allowed (design ) stress should be (36/1.5)-18.2 Ksi.

Then our design stress is 24-18.2 = 5.8 ksi, this is an important design criteria. If this
number is grater than 1 and less than 10 ksi, then leaves us some room for weight
optimization using this material, otherwise we would have to change the material for
another stronger.

8.2 Local Sensitivity Study

The objective of a local Sensitivity study is to look at small changes of the measures
(Von Mises stresses) for small independent variations of each design parameter used
(+-1to 2%).

Our design parameters for this study, as defined earlier are: plate thickness, the cut
location with respect to the left edge and the cut radius.

Design Controls:- This command can be used to define design controls which can used
later in a design study like global sensitivity, optimization etc. Design parameter can be
Dimension/Pro/Engineer parameter/section dimension. Section dimension option can be
used only if there some sections already defined in the model like a beam section.

Procedure:

Select: Analysis>Mechanica>Design Controls

AutogEM [ Analysis Tnfo Applications Tooks Window He




Select: Create

Click on Select

Click on the model and select the cut (notch). Select the 0.25 radius of the cut and
enter the text shown below. - —




|Local sensitivity Param. Setvalues at approx. plus an
minus 1 percent nom wal.

Dimen

Click on Accept

Repeat the same procedure for the cut_length and plate thickness (see next graphics
for values to be entered)



For the cut length, select the 6” dimensions and enter 5.9 and 6.1 for the minimum
and maximum values



For the thickness, select the 0.25 inch dimension and enter 0.24 and 0.26 for
minimum and maximum values as shown below.

Click on Accept.



Once the parameters have been defined, the design parameter window should look as
follows '

cut_radius

Click on Done>Done/Return



Create a design study:
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Make the following selection for the study

Select notch_plate_Static under Analysis

Lacal Sensitivity

an n tivity Stucly of VM streses as a function nfthicknes, cut
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Select Accept



Run the local sensitivity study created (with the design study selected) click on Start
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window to see the results
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Final Results
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Click on the review result button

The following box appears

We are going to create results graph by plotting each design parameter versus the Von
Mises Stress measure. We are going to create three windows, one for each parameter
previously defined. Name the first result window as follows and fill out and make
appropriate selections as shown

Design Var

Click on Ok



Select max_stress_vm as a measure and select Design Var from the graph location,
make sure that the thickness variable has been selected

max_prin_mag
max_rak_mag

maw_rot_z
rmas_stress_prin
max stress ym
max_stress xe
max_stress_xy
max_stress_xz

ma ss L

- I Result Window Definition

Click Ok

Design Var




Click on the insert a new definition button

Insert a new definition

Repeat the procedure to create another window, change the design variable to Cut
Length

Result Window Definition

Click Ok



Repeat the procedure to create another window, this time change the variable to
cut_radius '

Restﬂi: window Definition

{VM_Cut_radius

Design Yar

cut_radius

Click Ok



Click on the display definition button
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the Final result
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Analyze how sensitive each parameter is to the Von Mises stresses.
The conclusion is:
The VM stress is sensible to all parameters

This was the main objective of the local sensitivity study. So we will carry all three
parameters into the next phase.

If our study indicates that the Von Mises stress is not sensible to any of our
parameters, then the parameter or variable which does not affect the Von Mises stress
is not taken into account for the optimization study.

Select: File>Exit Results>No>Close

8.3 Global Sensitivity Study

The objective of the global sensitivity study is to look at the variations of all
parameters into each step of the process as defined by the user




Select Review and review each parameter and change the minimum and maximum
values to the following magnitudes

Note that in practice, the designer would set these values according the final
dimensions and applications of the model

Click on Accept




Repeat the procedure with the other two variables

n Parameter Definiti

Select: Accept>Done>Done Return



Create a design Study Called: Glob_Sens_Study_1
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Note that the minimum and maximum values are set to minimize the plate weight as
the study progresses according to the results of the local sensitivity study

Analyses and Design studies




Click on the Status Icon to Check the Iterations

Click on the review result button

Fill out the dialog boxes with the following data
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Fill out the dialog box and click Ok

Repeat the procedure for the
following box

| hotch_plate_static
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This study was carried out to find the best combination of parameters that will be
taking into account on the final optimization study.

The conclusions we have are:
For minimum VM Stress, we need the following:
-Maximum Thickness

-Maximum Cut length
-Minimum Cut Radius

8.3 The Optimization Study on Total Mass

Click Edit>New Design Study
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Fill out the blank spaces, click on create and type the right value for the maximum
allowed stress, modify the rest of the values if it is necessary (we are going to use 10
iteration to save time, but the minimum suggested is 15)

Click on Accept, and Run the analysis, Click on the status button to check the
iteration process

Run the design study it will take between 20 to 30 minutes. Check the status file and
compare it to the one shown below.

The final values should be:
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Now, we are going to



Edit the design Study, and change the study from mass to max_stress_vm (goal)

Accept and Run the Study
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