
 
 
ME345 Modeling and Simulation - Professor Frank Fisher 
3D Thermal Analysis, Finned Pipe 
Last Updated October 2008 – Allen Umali 
 
Introduction: 
In this example you will learn to assess 3D geometries in heat transfer by modeling an object 
subjected to convection and temperature boundary conditions.  ANSYS will allow you to 
generate a plot of the nodal temperature and heat flux distributions along the geometry. 
 
Problem Statement 
Example 3-12 from Heat and Mass Transfer – A Practical Approach 3rd Edition 
Steam in a heating system flows through tubes whose outer diameter is D1 = 3 cm and whose 
walls are maintained at a temperature of 120 oC.  Circular aluminum alloy fins (k=180 W/m-oC) of 
outer diameter D2 = 6cm and constant thickness t = 2mm are attached to the tube.. The space 
between the fins is 3mm, and thus there are 200 fins per meter length of the tube.  Heat is 
transferred to the surrounding air at T∞ = 25 oC, with a combined heat transfer coefficient of  
h = 60 W/m2-oC.  Determine the heat transfer from the tube per meter of length. 
 
Objective Circular aluminum alloy fins line the length of the pipe. For simplicity, the heat transfer 
from the tubes per 10 cm of pipe is to be determined. A contour plot of the nodal heat flux 
distribution will be generated. 
 
Assumptions 1 Steady-state analysis 2 The heat transfer coefficient is uniform over the entire 
fin surface 3 Thermal conductivity is constant 4 Heat transfer by radiation is negligible 
 
Boundary Conditions 1 All areas of the pipe/fin combination have convective boundary layers 
2 The temperature at the base of the pipe is maintained at 120 oC. 
 
Dimensions (SI Units) 



 
 
Starting ANSYS - Click on ANSYS 11.0 in the Programs menu. 
 
Modeling 
 

 From the ANSYS Utility Menu, click on File > Import > IGES. The following window 
appears: 

 

 
 

 Click OK. The following window appears: 
 

 
 

 Click on Browse and choose the location of the downloaded pipe_fin.igs. An isometric 
view of the pipe/fin part should come up. The modeling portion is now complete.



 
 

Material Properties - With the modeling completed, the material model behavior must be 
defined.  ANSYS can then understand how heat travels through the composite solid (i.e. thermal 
conductivity of material). 
 

 In the ANSYS Main Menu, select Preprocessor > Material Props > Material Models.  
The following window appears: 

 
 

 For Material Model Number 1, click on Thermal > Conductivity > Isotropic.  The 
following window will prompt you for the thermal conductivity. 

 

 
 

 Enter the thermal conductivity for aluminum alloy, k = 180 W/m-oC. Material 
Model Number 1 now has an isotropic thermal conductivity of aluminum alloy. 

 Exit the Material Model window. 



 
 
Element Properties 
 

 The next step is to define the element type. From the ANSYS Utility Menu click on 
Preprocessor > Element Type > Add/Edit/Delete. In the Element Types window that 
appears click on Add. 

 In the Library of Element Types window choose Thermal Mass > Solid in the left window 
and select Tet 10node 87 in the right window. Click OK. Close the Element Types 
window. 

 

 
 
Meshing – This next section is responsible for defining the size of the elements, and ultimately 
the degree of accuracy of the solution. 
 

 In the ANSYS Main Menu click on Meshing > Mesh Attributes > Default Attributes, 
and confirm that the Element type number is 1 SOLID 87 and that the Material number 
is 1. Click OK. 

 Next we define the element size. In the ANSYS Main Menu, click on Meshing > Size 
Controls > Smart Size > Basic.  The following window appears: 

 

 
 

 Choose a size level of 7 and click OK. 



 
 

 Next click on Meshing > Mesh > Volumes > Free and click anywhere on the pipe/fin 
volume. Click OK. An error warning should occur. 

 

 
 

 If the warning does occur, we need to refine our mesh. In order to do this we must 
plot the elements that violate shape limits. Click on Meshing > Check Mesh > 
Individual Elm > Plot/Error Elements.  

 Click OK on the next window that comes up. ANSYS should plot the volume using 
lines to reveal the error element. 

 

 



 
 

 To refine the error element, click on Meshing > Mesh Tool. On the Mesh Tool window 
that appears, click Refine. Select the error element by clicking on it and click OK. The 
Refine Mesh at Element window appears. 

 

 
 

 Select 2 for the level of refinement and click OK. The volume should now be 
completely meshed with no error elements. Close the Mesh Tool. 

 
Loading - The next step is to define the loads or boundary conditions acting on the volume.  
 

 First we define the convection on the pipe area. Click on Preprocessor > Loads > 
Define Loads > Apply > Thermal > Convection > On Areas.  

 On the Apply CONV on Areas window select Pick All. 
 The film coefficient (convective heat transfer coefficient) was given as a constant  

h = 60 W/m2-oC. Enter 60 for the Film coefficient. 
 The surrounding temperature is given earlier as T∞ = 25 oC. Enter 25 for the Bulk 

temperature. 
 Click OK. 

  

 



 
 
The next step is to apply the given base temperature to the insides of the pipe.  
 

 NOTE: Selecting the inside of the pipe may be a difficult task.  It may be easier to 
change the view of the pipe as shown, and select in the vicinity of the red boxes 
shown. 

 
 

 First Click on the Dynamic Model Mode button       in the lower right hand corner of 
the ANSYS window.  

 Press and hold the right mouse button to rotate the pipe. When finished click on the 
Dynamic Model Mode button again to deactivate. 

 Click on Preprocessor > Loads > Define Loads > Apply > Thermal > Temperature > 
On Areas. 

 
 NOTE: If an undesired area is selected, you can toggle between “picking” and 

“unpicking” by clicking the right mouse button. 
 To select the inside of the pipe, click in the vicinity of the red boxes shown: 

 



 
 

 When selected, the inside of the pipe should be highlighted purple as shown. Click OK. 
 

 



 
 

 In the following window that appears, click on TEMP and insert a Load Temp value of 
120 oC. 

 

 
 

 Click OK. 
 The loading of the pipe/fin is now complete. 

 
Solution – The final step is to run the solution. 
 

 Click on Preprocessor > Solution > Analysis Type > New Analysis. In the following 
window be sure that Steady-State is selected. Click OK. 

 
 Click on Preprocessor > Solution > Solve > Current LS and click OK. Give ANSYS a 

few seconds to solve. The following window will appear. 
 

 
 



 
General Post-Processing 
 

 To view the solution, we can generate a contour plot of the heat flux. 
 Click on General Postproc > Plot Results > Contour Plot > Nodal Solution > Thermal 

Flux > Y-Component of thermal flux.  
 

 
 

 If the temperature distribution was required, ANSYS can also perform this by clicking 
General Postproc > Plot Results > Contour Plot > Nodal Solution > DOF Solution > 
Nodal Temperature. 
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Does ANSYS generate a reasonable solution? 
The second part of the exercise involves the comparison of ANSYS results to the hand calculations; our 
objective is to determine whether or not the ANSYS results are reasonable.  The problem statement asks 
us to solve for the heat dissipated by the pipe fins.  ANSYS can only solve for the heat flux along the fin, 
but not the actual heat loss. Still, we can arrive at a solution for the actual heat loss if we multiply the 
component fluxes by the corresponding normal fin areas. That is, 

 
where Q is the heat loss, q is the component heat flux, and A is the normal area.  Using the “NLIST” and 
the “PRNSOL” functions in ANSYS, we can output the flux solution for all of the nodes.  In addition, we 
can output the coordinates of each node to determine which nodes are relevant to the solution (i.e. 
nodes at the base of the pipe and along a fin).  We can filter the data in excel to find a sample of the 
nodes. 

 

Figure 1. NLIST function is used to find the coordinates of relevant nodes. 

Q  qA



 

Figure 2. PRNSOL function to list the heat fluxes for all nodes. 

Convection along the Fin: Y‐Direction Heat Flux 

It is important to first understand that the heat transfer to the surroundings by convection is not 
constant throughout the fin, because of the varying temperature distribution along the fin. The ANSYS 
results agree with this, as the Y‐Flux steadily decreases as radius increases (with the exception of the 
three outliers).  Because the flux is variable, we can either perform an integral of the Y‐heat flux per 
differential area along the fin, or take the average flux and multiply by the normal fin area. That is 



 

In order to perform an integral, an equation for the flux as a function of radius must be obtained by 
fitting a best fit regression with the data. Instead, we use the average flux of a sample of relevant nodes 
for the sake of simplicity. 

 

Figure 3. Flux values and x‐coordinate (radius) of relevant nodes after sorting in excel. 

Referring to Figure 3, the average y‐directional heat flux is calculated at 

. 

The corresponding normal area is the area along the diameter of the fin. 

 

Q  
r1

r2

qrdA  Qaverage ∗A

Node x coordinate Y-Flux Absolute Value Y-Flux
5028 1.50E-02 -5324.1 5324.1
5047 1.50E-02 -5332 5332
5399 1.53E-02 -5718 5718
5424 1.53E-02 -3263.1 3263.1
5425 1.68E-02 -4374.8 4374.8
5430 1.70E-02 -5383.3 5383.3
5454 1.70E-02 -5377.1 5377.1
5397 1.76E-02 -5781.1 5781.1
5426 1.76E-02 -2654.8 2654.8
5461 1.86E-02 -5405.3 5405.3
5484 1.86E-02 -5320.1 5320.1
5429 1.91E-02 -5500.6 5500.6
5455 1.92E-02 -5444.8 5444.8
5030 2.01E-02 -5351.1 5351.1
5427 2.05E-02 -5450.7 5450.7
5456 2.06E-02 -5464.5 5464.5
5428 2.10E-02 -5390.9 5390.9
5460 2.17E-02 -5374.3 5374.3
5485 2.17E-02 -5373.1 5373.1
5457 2.38E-02 -5360.4 5360.4
5486 2.39E-02 -5391.5 5391.5
5458 2.49E-02 -5417.8 5417.8
5459 2.49E-02 -5178.8 5178.8
5041 2.74E-02 -5320.4 5320.4
5039 2.93E-02 -5310.3 5310.3
5008 3.00E-02 -5291.2 5291.2

Average Flux 5175.157692
(W/m^2)

qy  5175.2 W/m2

Ay  r2
2 −r1

2∗2  0.032 −0.0152∗2  4. 241210−3 m2



The heat transfer via Y‐Flux is 

 

Convection at the base of pipe and at fin tips: X‐Direction and Z‐Direction Heat Flux 

Similarly, the x‐component fluxes along the base of the pipe and at the tip of the fin can be multiplied by 
the base area and fin tip area, respectively, to find the additional convection at these locations.  It makes 
sense to take the x‐component fluxes along the x‐axis at the mentioned locations and distribute these 
values along the circumference of the geometry. Hence, the z‐direction fluxes need not be read.  
Moreover, one will find that the x‐fluxes along the x‐axis are similar to the z‐fluxes along the z‐axis. 

The x‐component fluxes along the x‐axis at the base of the pipe and tips of the fins were found with 
PRNSOL on average to be approximately 

    
One un‐finned area of the pipe base is the base circumference multiplied by one base length. 

 
One fin tip area is the fin circumference multiplied by the thickness of the fin 

 
The total additional heat transfer from the base and fin tips is 

 

The total heat transfer by convection for 200 fin and un‐finned areas is  

 

Comparing ANSYS with Hand Calculations 

The answer using the method presented in the book gives an answer of 5380 W. ANSYS generated a 
heat loss of 5376.6 W. The error is approximately ‐0.06% or ‐0.0006 and is sufficiently small enough to 
verify that the ANSYS results are reasonable. 

 

Qy  qyAy  5175.2∗4. 241210−3  21. 949W

qxz_base  10582.2 W/m2

qxz_tip  5151.2 W/m2

Axz_base  Cbase lbase  2rbasel  20.0150.003  2. 827410−4 m2

Axz_tip  Ctiptfin  2rtiptfin  20.030.002  3. 769910−4 m2

Qxz_total  qxz_baseAxz_base qxz_tipAxz_tip

 10582.22. 827410−45151.13. 769910−4  4. 9339 W

Qtotal  200Qy Qxz_total  20021. 9494. 9339  5376. 6 W










