PRO-MECHANICA

Pro-Mechanica is a product of PTC. It works with Creo Pro/E in integrated mode to allow users to
perform structural and thermal analyses. This tutorial was originally written for UNIX platform, but
updated to be valid for the Windows version.

Lesson One < Structural > Beam
Cantilever Beam

Given: A cantilever beam with length L and a rectangular cross section with dimensions as shown
in Figure 1. The beam is subjected to concentrated load F applied at the free end.
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Figure 1.
F =100,000N,L=2m,a=0.050m, b =0.100 m,
Find:
(1) Shear diagram, moment diagrams, maximum deflection, and maximum von Mises stress using
Pro/Mechanica.

(2) Deflection of the beam using exact solution approach and FEM approximation solution approach
and compare the results.

Solution:

The general approach in Pro/M is as follows:
I- Create the model in Pro/E

II- Switch over to Pro/M integrated mode then

Assign material

Define geometric constraints
Apply load constraints
Define the type of analysis

III- Run the analysis

IV- Post-processing: Study the results and carryout verification.
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I. PRE-PROCESSING WITH PRO/E

STEP 1: Create a file name "beam" by clicking on the Ijicon or alternately, CTRL+N. A New File
dialog window will pop up. Enter "beam" and leave default settings of part type and solid sub-type.

STEP2: Set unit to mmNs setting by choosing File > Properties > Units > Change from Part
window. Select mmNs option followed by clicking on the SET button. Accept the "Convert Existing
Numbers (Same Size)" option from the Warning window. Click OKAY and close the Unit Manager
window.

STEP  3: Establish the beam by creating a curve with the sketch tool.

Click on the sketch tool curve creation icon . From CRV OPTIONS window, select Sketch ->
Done. For sketching plane, use the FRONT plane. Accept the default sketch orientation by clicking
Sketch (Reference: RIGHT, Orientation: Right).

STEP 4: In the sketcher mode, draw a line by selecting the line icon and draw a line aligned
with the TOP plane and symmetrical about the RIGHT plane. To do this, create a centerline along
the RIGHT plane and create a symmetric constraint between the two end points of the line and the
centerline (This is just my convention. You may choose your own reference system for the sketch
but you need to keep track of the coordinate system in which you define the line). Make change to
the dimension to 2000 from end to end as shown below.
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Once done, exit sketcher mode by clicking on the ’/ icon in the toolbar then click OKAY from the
Reference dialog box to complete the section definition.



II. PARAMETER DEFINITION IN PRO/MECHANICA

STEP 5: Entering Pro/M by selecting Applications -> Mechanica menu. A Unit Info window will
pop up to verify the unit setting you have defined back in Pro/E. Make sure review the displayed
setting and click on the check box to keep the display from poping again every time you are

accessing Mechanica within the same session.

STEP 6: From Mechanica menu, select Structure submenu.
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STEP 7: Defining beam's cross section. Use the Properties>Beam Sections command to define

the shape and size of the cross sections when you create beams. You can also define a beam
section and save it in a library file, called mbmsct.lib, for future use.

In the "Beam Sections" window, click on NEW button to enter the beam definition dialog box as

shown below.

Enter "rectsection" in the Name prompt (you may
choose whatever name you wish but you need to keep
track of the names for reference later on in the
session). Enter a description of your beam (optional).
In the Section group, pull down the Type menu and
choose Rectangle option as shown above. In the
corresponding dimension box, enter "50" for b
dimension and "100" of d dimension (note that the unit
is mm). After the completion of dimension entries, click
on OK followed by Close.

-
[T Beam Section Definition

[t

Mame

| rectsection
Description

| Rectangular section for exercise 1

| Section l

Type:| O Rectangle -

i~ Dimensions

— b — b: |50

+

l— i —ie]

d: | 100

E OK i | Review | | Cancel |



file:///C:/Mechanical/proeWildfire%202.0/html/usascii/proe/promec/modstr/props/reference/bm_add_lib.htm

STEP 8: Defining beam's orientation. Now that the cross section has been defined, you must specify
how the beam section is oriented with respect to a chosen coordinate system (WCS is default).
Select Properties > Beam Orientations and click on NEW to enter the Beam Orientation
Definition as shown in the screenshot below:

===

-
] Beam Orientation Definition

Mame Click Ok and Close

'Eleamt]rienﬂ

Description
Crientation of rectsection beam ‘

COrientation Angle
II:I ”degree

— Offsets

Location of: ‘
' @ Shape Origin(_) Shear Center

with respect to the beam action coord. sys. Note that the vector [0,1,0] defines the

orientation of the beam with respect to the beam

I action coordinate system. This vector will then be

D Irﬂﬂ’l "aligned" with the WCS in the following step.
DY: | 1 |
Dz:|0 |

| Ok | | Cancel |

STEP 9: Beam definition. In this step the beam material and orientation
with respect to the WCS is assigned/defined. Insert>beam. A Beam
Definition dialog will pop up as show below.

Enter 'Beam1' for Name
Select Edge/Curve from References pull-down menu.

Click on the “Select geometrical references” box then select the datum
curve you've created.

Click on Z£ 2 button and select Aluminum 6061 as the material to be
assigned to the beam.

Make sure Beam is selected under Type (default)
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Accept the default setting "Y-Direction defined by Vector in WCS" in the Y Direction choice. For X: 0;
Y:1; Z:0.

Make sure '"rectsection" (or whatever name you've chosen for the beam section earlier in the
process) is selected in the Section pull-down menu. Also check on the orientation name to be
"BeamOrientl" as you have defined earlier.

Leave [None] for Release

Click on OK button when done followed by Done/Return (if necessary). The rectangular sections
will appear along the beam in red color.

STEP 10: Applying geometric constraints (boundary condition). Select Insert ->Displacement
Constraint. A Constraint dialog panel will pop up. Enter the following:

Name: end_constraint

Member of Set: Constraintsetl

References: Select References>Points, then click “Select geometrical references,” then select the
left (negative x-axis) end of the beam. Leave the WCS as is and accept all default constraints in
both translation and rotation DOF's. This simulates the fixed-end condition of the beam.

Click on OK to complete the constraint definition. A constraint icon should appear next to the
constrained point you've created as shown below:

STEP 11: Applying loading condition. Select Insert -> Force/Moment Load.
In the Force/Moment dialog panel, fill in the followings:

Name: concentrated_load

Member of Set: (leave default "Loadset1")

Select References>Points from the menu, click “Select geometrical references” then select the
other end of the beam (the one that is not constrained).

Enter "-100000" in the Y-component box under Force group and leave all other zero.
Click OK button (You may use the Preview button to see the applied load).

You may also show the applied along with other constraints by selecting View -> Simulation
display to bring up the dialog panel as shown below (optional).
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ITI. ANALYSIS

STEP 11: Analysis type definition. From the main
Analysis>Mechanica
pop up
prompting you to select the type of analysis. Select

menu, select

Analyses/Studies. A dialog box will

File>New Static" from the pull-down menu.
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A Static Analysis Definition window will pop up. Enter the following:

Name: Staticl

Description: Static analysis of rectangular beam (or whatever you want to describe your analysis)
Use Multi-Pass Adaptive option for convergence with 10%
Select Local Displacement, Local Strain Energy and Global RMS Stress as the convergence criteria
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STEP 12: Carrying out the analysis. Select Start button in the Analyses and Design Studies dialog
box. This will initiate the 'number crunching' process in Pro/M. Choose NO when you asked if you
want to run interactive diagnostics. After starting the analysis, you may click on the Display Study
Status button to "watch" the computing process in a pop-up window.

The analysis summary is given in the Summary window. Make sure to stroll through the result and
understand the meaning of those values.

What is the value of von Mises stress from your run and what does it mean?

What is the value maximum deflection from your run?

You should do a quick hand calculation to check the result such as the maximum bending stress at
the fixed end. How is this number (max bending stress) compared with the von Misses stress
obtained from Pro/M?
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When the calculations are done select the review result button in the Analysis and Design Studies
dialog box.

Enter a name for the window. Click OK and ensure that the folder named "Staticl" is selected (this
is a folder in your working directory containing all the results from a particular analysis).

STEP 13: Shear and Moment Diagrams
In the "Result Window Definition" dialog, change Display type from Fringe to Graph.

In the Quantity menu, pull down and select Shear & Moment under Graph Ordinate (Vertical)
Axis. Uncheck all except for Vy and Mz.



Make sure "Beams" is selected in the Graph Location group at the bottom.

Click on the Select button in the Graph Location group. A new window showing the beam model will
pop up. Click on the beam. Make sure that you note the orientation of the beam according to the
coordinate system shown in the window (in three colors). You may find it a bit clear when you
rotate the model around. Click on the middle button on the mouse to exit this window. If prompted
for the graph start, ensure that the constrained end of the beam is selected. If not, change this by
pressing Toggle.

Leave Display in Graph mode and other default parameters unchecked.
Click on Accept button once complete.

An information dialog box will pop up. Click OK after reading the message.
Click OK then Accept and Show button.

The results should like this:
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Make sure to check the values you see on these diagrams.

STEP 14: Viewing von Mises Stress.

To obtain stress information, follow the same steps above only here we select Stress as quantity
under Result Window Definition dialog panel (accept the default Display type of Fringe). Also
select von Mises the component pull-down menu. In the Display Location tab, select ALL.. Make



sure Deformed box is checked in the Display Options tab and enter 10% for scale. To animate the
result (from no stress to maximum stress), check the Animate box. Then click OK and Show.

You may rotate the model around to have a better view of the beam deflection. A screenshot result
of von Mises plot is shown below.
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You are encouraged to explore the result mode and experiment with different features and options
such as displaying the maximum displacement and measurement of inertia etc.

To exit result display mode, select Exit result from File menu.

Additional Exercise: Use the same beam model you've created and apply a simply-support
constraint at the mid point of the beam (constrain in the y-direction with respect to the WCS).
Change the load from 100,000 N to 200,000 N.

Include in your report:



1- Plots of shear and moment diagrams

2- Plot of von Mises stress contour

3- Tabulated values of max. deflection and von Mises stress from FEM and your hand calculation
(make sure to include all steps of your calculation in the appendix).

4- Comments on the results including your justification of errors, if any.

5- Results from the additional exercise specified below with all components listed in items 1 thru 4.



