Sensitivity and Optimization Tutorial

Objective:
To demonstrate the use of Pro Mechanica in sensitivity and optimization studies.

Overview:

The purpose of an optimization study is to help the designer in optimizing certain design
parameters as a function of known measures, such as Von Mises Stress or maximum
displacement for a specific goal (i.e. Minimize total mass). The software can not do all
the work in the optimization process; this is only a tool the designer uses to get to the
final objective, so that the Designer’s knowledge plays a very important roll in any
optimization study.

The optimization study (Pro Mechanica) we are going to perform is divided into main
phases:

1. Design Phase I: In this part a static analysis is created and later is combined with
local and global sensitivity studies in Pro Mechanica. In this phase, Pro Engineer
Wildfire 2.0 is used to set the Design parameters.

a. The Main objective of a local sensitivity study is to look at changes of the
measures, Von Mises in most cases, for small variations of each design
parameter (*- 1%) independently.

b. The Objective of the global sensitivity study is to look at the variations of
all parameters, within their respective range, into each step of the process
as defined by the user.

2. Design Phase II: Completes the optimization of the part according to your desi gn
objectives (goals). All parameters are optimized concurrently. A goal could be to
minimize the total mass or the total cost of the model



Procedure:
The procedure to carry out the Optimization process is as follows:

1. Create the part in Pro/Engineer

2. Switch to Pro/Mechanica mode and create a shell mid-plane compression
idealization (assign material properties)

3. Create the mesh and boundary conditions (loads and constraints)

4. Run a quick check analysis to know if the model converges to a solution with
respect to a measure (Von Mises Stress)

5. Set up Design parameters for the preliminary design study

6. Run a local sensitivity study and select parameters that have an effect on the
measures predetermined

7. Run a global sensitivity study on selected parameters and find the parameter value
(maximum and minimum) that has the greatest effect on the measure

8. Run an optimization study for the above parameters, setting the starting point of the
study using the findings of point #7 above. Optimize for your design objective(s). The
design objective for this case is to minimize the mass of the plate.



The following figure shows the model that will be used for the study. It’s a simple
plate with two notched cuts located 6 in. from the left end. The loads are applied at
the tip of the right end of the plate, while the left end is constrained (where the
coordinate system is)

Figure 1 (Notched Cantilever Beam)

The Design objectives are to optimize the location and radius of the notch with
respect to the left end of the plate. We will also look at plate thickness and optimize

all three parameters above for the total mass, using the Von Mises stresses as the
measure.



Please, refer to model represented in Figure 1. It is a plate made of Steel, now, we are
going to define the objectives and determine the measure to be studied for the
selected design parameters.

Optimization Measure to be Design Parameters to be optimized
Goal used for
Optimization
Minimize Von Mises Stresses Name Description Initial
Weight of the Value(in)
part Cut_length | Dimension 6
from left
edge to cut
Cut_radius | Notch radius 0.25
Thickness Plate 0.25
Thickness

Before starting the procedures below, create a directory named Opt_Study, using
Microsoft Explorer. Copy the part named Plate_Tutorial to that directory

Note: Integrated Mode in Pro/Mechanica: This mode can be accessed via
Applications-Mechanica-Structure-Model. This mode can be used for structural
modeling of a part/assembly i.e., define all the simulation modeling entities and
prepare the model for finite element analysis.



1. Open the file Plate_tutorial

Once open, the following part show up on your screen

| PRT_CSYS DEF
z

2. Switching to Pro/Mechanica (Integrated Mode)

Select Applications>Mechanica
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A new dialog box appears, select structure and 3D
analysis

Click on Ok

Model Type:- Opens the model type definition dialog form.
Lets the user define the model type. Default model type is
always 3D. If the model type selected should be 2D, user also
has to select the Geometry and the associated coordinate
system.

3D

2D Plane Stress

2D Plane Strain

2D Axisymmetric

If the model is a 2D model, all geometry, loads and
displacements must lie in the xy plane of the Cartesian
coordinate system. For 2D axisymmetric models, all
coordinates must be positive in X in the XY plane.

-
[ Mechanica Model Setup u

o Capability Mode 1
[] Mechanica Lite

l-— Model Type .|
| Structure '|
— Mode .|
(] FEM Mode

— Type
i@ 3D
(") 2D Plane Stress (Thin Plate)
() 2D Plane Strain (Infinitely Thick)

() 2D Axisymmetric

— Coordinate System

— Geometry

Surfaces, Edges, Curves

l-— Default Interface .|
| Bonded T |

| Ok | | Cancel |

A new group of buttons (tool bars) appears on the right of your screen (These are the

Pro/Mechanica tool bars)
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Idealizations:- The Following idealizations are available in the Integrated Mode — Shells,
Beams, Masses, Springs. These idealizations should be used whenever possible as they

require less computation time. Another advantage of using these models is that they are
easy to model.

For this exercise we are going to create a compressed shell idealization (the thickness
of the plate permits to do it).

Select Insert>Midsurface

Select one of the surface of the plate, the other one will be selected automatically.

Click on Close.

| @ shell Pair Definition L = |

Wsi:::ain ﬂ

e 1
@ Constant () Multi-Constant

References
Auto Select Opposing Surfaces
Surfaces

Surface
Surface

Pair Properties
Placement

[ Midsurface ']

| No items |

["] Extend Adjacent Surfaces

Material Properties
Material ‘
ﬁ(Pan Material) v || More... |
Material Orientation

[ (None) 'I[ More... ]

(] (v][x




3. Assigning Materials Properties to the Model

Materials:- This option selects the user define/select the material for the model. There
are many standard materials listed as Materials in Library and the user can assign one of
those standard materials to the part(s) and the user can also preview the properties of the
standard material by clicking on the “Edit” button on the right hand side. User can also
create a material of his/her own choice by clicking on the “New” button on the right hand

side.

The plate is made of standard ASTM A-36 Steel (36 ksi yield strength). Select

Properties>Materials (see next page) and the following window will come up

Select steel from the left column and click on the arrow to move in under the
materials in model column.

==

[ Materials .&
File Edit Show
e X &
O g g X
— Materials in Library
[ — . .
(SAS A » Material Directory
Bl Organize v - 7 Tools ~
|| | Common Foiders [yal2014.mtl
|| | [#] Desktop [yal6061.mtl
Il | & MyDocuments E‘?}brassmtl
Il @ oy bronze.mtl
G fieldo19 Cycum
£% Working Directory [y epoxymt
Material Directory [ gyfe20.mtl
24 Favorites [gyfe30.mtl
[y fed0.mtl
[y fe60.mtl
[ femall.mti
[&yfenodrmtl
[&yma.mt
[y nylon.mti
[y pvemtl
[Eyss.mt
[ steel.mtl
[gytially.mtl
[y tipure.mtl
[@ytungsten.mti
» Folder Tree

v |5 | I'search..

2 3

— Materials in Model —,

STEEL

IE‘ Cancel ’




Properties AutoGEM Analysis

Select Properties/Material Assignment

Info Applications Tools Wil

L Materials... Iy [:] l,}-—.,l %_3 ©
||\ material Assignment.. |} —

‘&z Material O

[ Load Sets

‘E’a Material Assignment

Create a Material Assignment to a model/volume

[k Constrain

{1, Shell Properties..
thx Beam Sections...
v, Beam Orientations...
7 Beam Releases...
2, Spring Properties...
£ Mass Properties...

Click “OK”.

Material Assignment -v :

— Name
| MaterialAssign1

=]

References

[ Components

Part: PLATE

Properties —— M
ﬁdaterial l

STEEL * || More... |
Material Orientation
l (None) '|| More... ]

| ok || cancel |




4. Creating a Mesh on the Model

We will keep all default shell elements and settings that AutoGEM will create. Select
AutoGEM >Create

AutoGEM = Analysis Info Applications Tools Window Help

4 conrol. AH%e-aa@ArsR soa0e QARE
5 Create... |

Settings.
1 selected All
Review G Create a Se

Geometr| Create p-mesh for Geometric Element Modeling

Solid
Midsurface

@ Solid / Midsurface
—

Structure @ 3D @ Native Mode : Default Bonded Interface

AutoGEM:- This command can be used to review the mesh before running any analysis.
The advantage of using AutoGEM is that if the model fails to create elements after
performing AutoGEM operation, we can identify which portion of the model was
creating the problem. Please note that it is not mandatory to perform AutoGEM before
running an analysis. If AutoGEM is not performed, elements are going to be created
during the running of an analysis.



After selecting create the following Selection Box appears

Click on Create

f _J AutoGEM LSZ—J.

File Info

[— AutoGEM References

All with Properties *| [create |

] |

This confirmation of the elements box should come up.

Select Close

) AutoGEM Summary LJX Diagnostics : AutoGEM Mesh
Entities Created: File Edit View Info
Beam: 0 Edge: 28
Tri 2 Face: 11 : | Source
Quad: 9 Face-Facelink. 0 Simulation Diagnostice
Tetra: 0 Edge-FaceLink: 0 .. @Atotal of 11 eleme AutoGEM
Wedge: 0
Brick: 0
Criteria Satisfied:
Angles (Dearees):

{ Min Edge Angle: 1252 Max Edge Angle: 125.99
MaxAspect Ratio: 9.61 4 i PN

Elapsed Time: 0.00 min CPU Time: 0.00 min




Click on the setup simulation display button on the toolbar

“ ‘
nodes were created. / el ]1
| @ Simulation Display [ %
' settings | Modeling Entities | Loads / Constraints | set Visibilities | Mesh
ﬁ = k3 — Mesh Entities
Mesh Points Beams
Solids Links
Shells Bonding Elements
M—| |o—
‘I}f-— \u—
— Mesh Display

[v] Shrink Elements |10 I: %

Display Shells with Zero Thickness
Display Quality
() Fine

() Medium

@ Coarse

Show Simulation Entities




Use the display seeting to shrink all elements to 10%. Click on Preview.

This is the mesh for the model

Now, unselect shrink elements options in the simulation display dialog box and click
Ok, Click Close on the AutoGEM box

Click Yes to save the mesh

Do you want to save the mesh ?
No may resultin a loss of work.

[ No | |[cancel |




5. Boundary Conditions on the Model

Constraints/Loads:- This menu is used to define loads and constraints for the model.
Please note that the default coordinate system is WCS and the user has the option to
either select a pre-defined coordinate system or define and select a coordinate system on
the fly. It is advisable to “preview” loads before hitting OK button just to make sure
everything is right.

5.1 Loads

The end load has 500 Lbs in both the X and Y directions. We will set this load as end
edge load.

Select Insert>Force/Moment Load

File Edit View Insert Properties AutoGEM Analy5|s Info Apphcatnons Tools Window Help

: [#- Force/Moment Load... B -m% ¢ -AaQ@Q s F @ &
E Pressure | nad
=) |z] @ Beari B— Force/Moment Load =]

® Atotal of 0 elemen!
& i Bl Gravil create a Forcemoment Load | 3 l All Sele
[+ Centrirerg

Temperature Load 4

Lty

Model Tree

[k Displacement Constraint...
(J PLATEPRT | 1\ Planar Constraint...
& Pin Constraint...

..... s7FRONT | @ Ball Constraint...
----- %4 PRT_CSYS | 4|k Symmetry Constraint...

) Extrude 1 D shell.

..... W Sketch 2 | I Beam...
+-¢) Btrude2 | 3 Spring...
----- & Insert Here £ Mass.

+-4g Materials
+-'6g Material Ag Midsurface...
+- 38 Idealization

Connection

& Simulation Measure...

Model Datum
[@ Surface Region...
Volume Region

[&@] Mechanism Load...




The following Dialog box appears: (3 Force/Moment Load . =
Change the name of the constraint set, [—name ]
select Edge/Curve, and use the following end_load I
force components: 500 and -500 in the X Member of Set
and Y direction []_LoadSeh *|[ New.. ]]
Select the arrow on the references part of e
the Force/Moment dialog box and select [EdgesiCurves -]
the right vertical edge from the model |: g e
g . . Ed
Click Preview to see how the constraints -
are applied on the model
Click Ok Properties
CSYS:@ World () Selected ]
[sLwes | Advanced >>
Force Moment
| Components hd I | Components v I
X 500 l[x: [o
Y |-500 Y o
iz o Mz
linlbm/sect2  ~| [in"2lbm/sec'2 |
|___gjg_ | l PreviewJ [ Cancel ]

LS

Your model should look like the following graphic




5.2 Constrains

The plate is a cantilever beam with the left end being fixed. To apply the end
constraints, select Insert>Displacement Constraints

fr—
Fle Edit View Insert Properies AutoGEM Analysis Info Applicati

=] |E
1 (R4 B o5
o
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= B £ #
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Change the name of constrains, select the edges/Curves on reference and select the left
vertical edge of the model

(3 Constraint B X ‘

| rnam ]
A [end_Constraints ][_!J

/| — Member of Set
[|—ConstraintSet1 v || New.. ]]

References
| Edges/Curves |
Edges/Curves : @ Individual(") Intent
il | Edge

~— Coordinate System \
| |@ world ) Selected

P |
— Translation w
X o [R]pe s
Y s [Rlpe 3
z s Bt

|
|
|
| NiA |

Rotation
X —{alé
.

[15Z

|
|
|
| /A |

- ™ | Cancel | |




The plate FEA model should look as follow




6. Static Analysis

We are going to create a quick check no convergence analysis named Static_1 to
make sure that we can get to a solution. Results are not important at this point, we just
want to make sure that the model can get to a solution

Select Analysis>Mechanica Analyses/ Studies

AutoGEM Analysis Info Applications Tools Window Help
o : + AB

.)(:. [;%ﬁ Measure b'@@@ﬂ'ﬁhgmﬁ]

5] e} Model :
. U

Geometry

= R

v v v 2w

External Analysis 3 ‘ All Selectabl

& Tolerance Study...
..-ﬁ Y [ Performance Monitor

»uy Saved Analysis

uyg Hide Al

Delete All »

[.E} Mechagica Analyses/Studies...
%1 Results...

|

Select New Static and enter the information as shown below

Analyses and Design Studies M

= |

File Edit Run Info

New Static...

New Moda
- New static anatysis}
New Bucklire

New Fatigue... Status

New Prestress 4
New Dynamic »

New Standard Design Study...
New Sensitivity Design Study...
New Optimization Design Study...

Close

[— Description '




Static Analysis Definition

Name:

[quick_check

Description:

— Constraints
[} Combine Constraint Sets

~— Loads
[]'Sum Load Ssts

’ VName” 7 ‘ Cpmponent | Name 7 ) 7Comrponent '
ConstraintSet1 PLATE LoadSet1 PLATE
4 b d4( ) »

[] Nonlinear [ Inertia Relief

Load | Temperaiure| | Excluded
Intervals Distribution Convergence | Output Elements
— Method
| Quick Check v

— Polynomial Order

Minimum: 3
Maximum: 3

| ok || cancel |

Select OK



Click in Start, answer yes to activate the error dection

Analyses and Design Studies

File Edit Run Info
. d|#\ Start __ =
7 B A B =
— Analyses a /~ S[I Start run b
Name Batch... Status
quick_ch — atic Not Started
Settings...
— Description

Click on Display study status to see if we can get a solution

- =
@ Run Status (quick_check.rpt) Not Running — ﬂ
Summary . Log | Checkpoints f
max_stress_xx: 1.941327e+04
max_stress_xy: 3.826795e+83
max_stress_xz: 0.000000e+00
max_stress_yy: 4.513252e+083
max_stress_yz: 0.000000e+080
max_stress_zz: 06.000000e+060
min_stress_prin: -1.632281e+064
strain_energy: 1.195698e-02
|Analysis "quick_check'™ Completed (16:50:83)
Memory and Disk Usage:
Machine Type: Windows XP 64 Bit Edition

Total CPU Time

451 .\quick_check

Total Elapsed Time {seconds): 3.55
{seconds): B8.58
Maximum Memory Usage {(Kilobytes): 1774580
Working Directory Disk Usage (kilobytes): @

Results Directory Size (kilobytes):

RAM Allocation for Solver (megabytes): 128.0

/Run Completed
|Fri Jul 26, 2613

16:508:03




Click Close

Now, we are going to create a Multi Pass Adaptive convergence

Edit the quick check analysis (right mouse click on it and select edit)

Enter the information as seen in the box below

T |
Analyses and Design Studies M
File Edit Run Info
JRX AMNE B T
Analyses and Design Studies
Name Type Status
./ quick_check — Completed
Edit... .
Copy
Delete
Start
Stop
Description
r =] status... l




’
Static Analysis Definition E‘
Name:
f notch_plate_static |
Description:
— Constraints — Loads
[] Combine Constraint Sets [] Sum Load Sets
Name Component Name Component
ConstraintSet1 PLATE : LoadSet1 PLATE
4 ) » 4( ' R
[ Neonlinear [ Inertia Relief

Load . Temperature | Excluded
i | Convergence
Intervals Distribution ge Output Elements

— Method

| Multi-Pass Adaptive v

— Polynomial Order

| Minimum [1_
Maximum r9|_

- — Limits \
| | ]

Percent Convergence |10 [

1D|4D

— Converge on :
@ Local Displacement, Local Strain Energy and Global RMS Stress .
| () Local Displacement and Local Strain Energy
() Measures

&3

[ OK ] l Cancel ]

Select Ok, then run the analysis. Answer Yes to activate the error detection. Click on
Display study status to see if we can get a solution



Run Status (notch_plate_static.rpt) Not Running g

Summary |Log ’ Checkpoints ‘

max_stress xx: 1.941327e+84 16.0% =
max_stress xy: 3.826795e+03 208.4%
max_stress xz: §.066006080e+80 8.08%
max_stress yy: 4.513252e+83 2.0%
max_stress yz: §.600680e+068 8.6%
max_stress_zz: §.000000e+806 8.0%
min_stress_prin: -1.632201e+84 8.2%
strain_energy: 1.195698e-02 8.9%

Analysis "notch_plate static” Completed (16:55:36)

Memory and Disk Usage:

Machine Type: Windows XP 64 Bit Edition
RAM Allocation for Solver {megabytes): 128.8

Total Elapsed Time (seconds): 6.85

Total CPU Time {(seconds): 08.83

Maximum Memory Usage {kilobytes): 177954
Working Directory Disk Usage (kilobytes): 8

Results Directory Size {(kilobytes):
724 _\notch_plate_static

Run Completed
Fri Jul 26, 20613 16:55:36




6.1 Results of Static Analysis
Create a Von Mises stress definition sheet as follows:

Click on the review result button

.

(3 Analyses and Design Studies

File Edit Run Info

ZBX AAEH BT

Analyses and Design Studies

| Review results of a Design Study or Finite Element analysis
| Name Type " Status
./ notch_plate_static  Standard/Static Completed

- |

Fill out the result window as follows:

W
@ Result Window Definition @_}‘

Name Title
\window1 || vM Stress Resuits |
Study Selection
Design Study Analysis ]
f = ]lnotch _plate_static | [ notch_plate_static 'l
Display type
[l—Fringe v ]]

Quantity [Dispiay Location ' Display Options |

| Stress v H Ibm/(in sec"2) ']
Component
[ von Mises ']
Include contributions from shells
Membrane Bending Transverse Shear]

\ At| Maximum v ][ of shell top/bottorr ']

OK l | OK and Show ' Cancel




Click on Display Options Tab

Check out the Deformed, animate and continuous Tone boxes

3 Result Window Definition

Name Title
|Window1 HVM Stress Results |
Study Selection ]

Design Study Analysis
[ = Hnotch _plate_static H notch_plate_static 'I

Display type
[[_Fringe v |]

[Quantity ' Display Locaﬁonl Display Options ]

Continuous Tone Deformed
(¥ Overlay Undeformed
Legend Levels 9 ¥ kvenay erorme
[:E:l (] Transparent Overlay
("] Contour | Scaling|10 %
[] Label Contours
SESrcas Show Element Edges

Show Loads
Show Constraints
(| Show Bonding Elements

Animate ‘
Auto Start

57 ) @)
Frames| 8 : I

ok | [okandshow|| Cancel




Click OK and Show

Untitled : (21 © il
File Edit View Insert Info Format Utlilities Window
SUFSTUERXBRITIARAAQ R T » B 4P sov—{F—rast
Working on frame 8. a
Updating the display ... ®
1.888e+B4

Static Analysis Von Mises Stress Results

Select File>Exit Results>NO

As we can see in the Von Mises Stress Analysis, the max Stress is 1.82 x10* Psi, the

material has an Sy =3.6 x10%, as it is a static analysis we can use a security factor of
1.5, so that our maximum allowed (design ) stress should be (36/1.5)-18.2 Ksi.

Then our design stress is 24-18.2 = 5.8 ksi, this is an important design criteria. If this
number is grater than 1 and less than 10 ksi, then leaves us some room for weight

optimization using this material, otherwise we would have to change the material for
another stronger.



6.2 Local Sensitivity Study

The objective of a local Sensitivity study is to look at small changes of the measures
(Von Mises stresses) for small independent variations of each design parameter used
(+-1 to 2%).

Our design parameters for this study, as defined earlier are: plate thickness, the cut
location with respect to the left edge and the cut radius.

Design Controls:- This command can be used to define design controls which can used
later in a design study like global sensitivity, optimization etc. Design parameter can be
Dimension/Pro/Engineer parameter/section dimension. Section dimension option can be
used only if there some sections already defined in the model like a beam section.

Procedure:

Select: Analysis>Mechanica Analyses/Studies

Analysis Info Applications Tools Window Help

Wesstie 'praca@stsh 8600
B | k
Model >
Geometry »
External Analysis » 5 | All Selectable 9
& Tolerance Study... B_
Performance Monitor @ 77
sy Saved Analysis &£
uag Hide All Dl A~
: B—e x’
Delete All » x %
v,
- A X

E Mﬂﬁ @ica Anailiysresﬁléfuai'es...

%] Results... - [§ 00

I &1_-] Mechanica Analyses/Studies m o
Run a Design Study Z §
‘ L.m T |




File>New Sensitivity Design Study

Analyses and Design Stinies (S|

File Edit Run Info

New Static...
= |
|| New Modal...

New Buckling...

New Fatigue...  Status
New Prestress » F Completed
New Dynamic »

New Standard Design Study...
| New Sensitivity Design Study... ’
New Optimization Design Study...

Close
—_—

r Description ]




Define study name>Type Local Sensitivity>Select dimension from model

Sensifivity Study Defudtio =) -
'Name E 7
local | 7
Description : iﬁ ;

gl o~
e o
1 %
Type
; Local Sensitivi§> E§ 9"
— Analyses & S

notch_plate_static (Static)
regenerate (Model Regeneration Only)

~— Variables

Variable Current Setting Units

\
2

Select dimension from model

LWERHLIANOY HE

| ok || cancel |




Click on the model and select the cut (notch). Select the 0.25 radius of the cut and
enter the text shown below.

(O select  (WES

[Selditem
|[_ok | [cance ||

o

1 [in b

Click OK



'

Sensitivity Study Definition

Name

‘ local

Description

Type

Local Sensitivity

4

Analyses

' notch_plate_static (Static)
regenerate (Model Regeneration Only)

— Variables
Variable Current Setting Units
cut_radius 0.25 0.25 in

wm

| ok || cancel




Repeat the same procedure for the cut_length and plate thickness (see next graphics
for values to be entered)

s ]
Sensitivity Study Definition
Name
[Iocal ]
Description
Type
Local Sensitivity v
I Analyses
| | | notch_plate_static (Static)
regenerate (Model Regeneration Only)

— Variables S
Variable Current Setting Units m
cut_radius 0.25 0.25 in pr—
cut_length ] 6 in =%
thickness 0.25 0.25 in =
4 ] >

[ 0K ]l Cancel

Click on OK



Run the local sensitivity study created (with the design study selected) click on Start

1
Analyses and Design Studies

File Edit Run Info

B X WA % |
‘ Analyses and Desim

Name ype Status
local Local Sensitivity Not Started
7/ notch_plate_static ~ Standard/Static Completed

( Description ]

Click on Yes to activate the error detection

( ign Studi L= ] ~
Analyses and Design Studies L J it e

File. Edit Run Info File Edit View Info

/ X ‘\ A % ’ Source Algno...

Analyses and Design Studies Simulation Diagnostics B
( ] @ Atotal of 0 eleme Solver

Name Type Status @ Startinia | | Sof
: e o arting local sen Solver
J local Local Sensitivity Completed .@ Beaqin gase analv Solver
7/ notch_plate_static  Standard/Static Completed g y

@ Begin sensitivity ¢ Solver
@ Begin sensitivity  Solver
~-@Run completed Solver
4 D) P o4 ) b

C
C
C
@ Begin sensitivity ¢ Solver C
C
C
C

[— Description




It takes approximately three minutes to complete the analysis. Check the status
window to see the results

.
Analyses and Design Studies

Run Status (local.rpt) Not Running

File Edit Run Info

7 BX AANE

|

Name Type
 local Local Sensitivity
W notch_plate_static  Standard/Static

Analyses and Design Studies —[ Display study status

Status

Completed
Completed ‘

[‘ Description

Click Close

Load Set: LoadSet1

max_beam_bending: -06.000000e+00
max_beam_tensile: -8.000000e+080
max_beam_torsion: -08.000000e+00

max_beam_total:

max_disp_mag:
max_disp_x:
max_disp_y:
max_disp_z:
max_prin_mag:
max_rot_mag:
max_rot_x:
max_rot_y:
max_rot_z:

max_stress_prin:

max_stress_um:
max_stress_xx:
max_stress_xy:
max_stress_xz:
max_stress_yy:
max_stress_yz:
max_stress_zz:

min_stress_prin:

strain_energy:

-0.8660080e+60
-2.802241e-064
-3.871234e-05

1.964461e-84
-2.325949e-18
-8.08979083e+04
-2.442807e-65
-2.84616%9e-280

2.701477e-19

2.442807e-085
-8.0897903e+04
-7.867077e+084
-8.088861e+04
-1.261165e+04

2.136367e-11
-1.886522e+04
-2.986716e-12

3.125654e-28

6.800838e+04
-4.982076e-062

Use Results to plot measures.

Y Loglf“ L t

inertia_yy: 4.885867e+02 >
inertia_yz: 3.735963e+00

inertia_zz: 5.186088e+ 02

——————




Click on the review result button

@ Analyses and Design Studies

File Edit Run Info

fxﬂﬁ(@]b

— Analyses and Design Studies r
lReview results of a Design Study or Finite Element analysis
| Name Type "
 local ‘Local Sensitivity ‘Completed
7 notch_plate_static  Standard/Static Completed

- |

The following box appears

We are going to create results graph by plotting each design parameter versus the Von
Mises Stress measure, We are going to create three windows, one for each parameter
previously defined. Name the first result window as follows and fill out and make
appropriate selections as shown



Result Window Definition j
Name Title
| Window?1 || vM_thickness ]
Study Selection
!rDesign Study Analysis
[ = Hlocal || notch_plate_static '|

Display type ]
E GrapD ']

Quantity lDisp!ay Location ' Display Options
— Graph Ordinate (Vertical) Axis

| Measure v |

ndefined |

g

3%

Graph Location
I Design Var Y, ”

thickness:PLATE S |

o —

| ok ||okandshow|| cancel |

Select max_stress_vm as a measurc and select Design Var from the graph location,
make sure that the thickness variable has been selected



Measures

| T

Predefined User-Defined

max_disp_z -
max_prin_mag

max_rot_mag

max_rot_x

max_rot_y

max_rot_z
max_stress_prin
max_stress_vm
max_stress_xx
max_stress_xy
max_stress_xz
max_stress_yy

Description
maxvon Mises stress over model

Show Predefined Measures l oK l l Cancel ]

Result Window Definition
Name Title
|\ Window1 || VM_thickness |
Study Selection
’Besign Study Analysis
[ = ]llocal H notch_plate_static v |
Display type ]
| Graph ']
Quantity ]Vtr\isplary Locatxdn Dis;ﬁlay d;)tions
— Graph Ordinate (Vertical) Axis ‘
| Measure vl
—
@\ max_stress_vm D) [1omi(insecr2) |
— Graph Location
” Design Var Y ”
' thickness:PLATE ¥ l
OK ‘ I QKAan_d\Sh_ow] [ Cancel ]




Click on OK and Show

@ Untitled i [~ [E=REERT)

File Edit View Insert Info Format Ultilities Window

s Il XRRNAR RGP N> B«

Fast

{ Insert a new defintion |
Preparing result window lvmmy—" -

Updating the display ...




Click on the insert a new definition button

Repeat the procedure to create another window, change the design variable to Cut Length

r Result Window Definition @
Name Title
\Window2 'lvM_Cut_length [
— Study Selection ———— )
1 Design Study Analysis ‘
| & ||local || notch_plate_static |

— Display type
‘ Graph

Quantity lih.—:-;,‘.a‘, Location ' D

isplay Options

‘-~ Graph Ordinate (Vertical) Axis

| Measure

| a% || max_stress_vm || 1om / (in sect2)

— Graph Location
' Design Var

| cut_length:PLATE

OK | [OKand ShowH Cancel

Repeat the procedure to create another window, change the design variable to Cut_radius
Click on OK and Show



Local Sensitivity Study Parameters Results

File Edit View Insert Info Format Utilities Window

COHSBUERXRRERALGR > B 4 pisov—F s

Preparing result window "Window1" (1 of 3) ...
Preparing result window "Window2" (2 of 3) ...
Preparing result window "Window3" (3 of 3) ... »
Updating the display ... 6]

Analyze how sensitive each parameter is to the Von Mises stresses.
The conclusion is:
The VM stress is sensible to all parameters

This was the main objective of the local sensitivity study. So we will carry all three
parameters into the next phase.

If our study indicates that the Von Mises stress is not sensible to any of our
parameters, then the parameter or variable which does not affect the Von Mises stress
is not taken into account for the optimization study.

Select: File>Exit Results>No>Close



6.3 Global Sensitivity Study

The objective of the global sensitivity study is to look at the wvariations of all
parameters into each step of the process as defined by the user

Procedure:

File>New Sensitivity Design Study

Analyses and Design Studies M

File Edit Run Info

New Static...
=
|| New Modal...

New Buckling...

New Fatigue... Status

New Prestress P Completed
C Completed

New Dynamic »

New Standard Design Study...

| New Sensitivity Design Study... |

New Optimization Design Study...

Close

[— Description ]




Define study name>Type Global Sensitivity>Select dimension from model>Select the
three variables from the model>Define the start and end values of each variable as below

-
Sensitivity Study Definition | = |

Name
| Global |
Description

Type
| Global Sensitivity
— Analyses

notch_plate_static (Static)
regenerate (Model Regeneration Only)

4

— Variables

’7 Variable | Current | Start End » Units - @
cut_radius 0.25 0.1 05 in —
cut_length 6 4 ; in ‘i
thickness 0.25 0.135 0.375 in =

Steps| 10 : ' Options...

[ OK H Cancel ]

I

Click on OK



Run the global sensitivity study

Analyses and Design Studies g

File Edit Run Info

/B X AAE B 3|

: Analyses and Desm
Name ype Status
Global Global Sensitivity 'Not Started
W local Local Sensitivity Completed
7 notch_plate_static  Standard/Static Completed

f Description X




Click on Review result button

Fill out the dialog boxes with following data

Result Window Definition E
Name Title
] Window1 ‘ ’ VM_thickness_gss |
Study Selection
[E)esign Study Analysis
[ = ][ Global H notch_plate_static v |
— Display type 1
| Graph .|
Quantity l Display Location ' Display Options

N-— Graph Ordinate (Vertical) Axis

| Measure

| % Hmax_stress_vm? |[1bm(insecr2) |

— Graph Location

‘l Design Var

| thickness:PLATE

OK | |oKandshow|| cancel |

Click on Ok and show

Click on the insert a new definition button

View Insert Info Format Ulilities Window

s@ERXRRER Q!

sers\zheni Insert a new definition bobal\dpiupdﬁ'
At window




Repeat the procedure to create another window, change the design variable to Cut Length
and Cut Radius

Click on Ok and show

@uied i i
1L D o I ooyl e o1, it i 1 o AT A L
CHUEBBERXENNEARART 5> W r ] i
ol eeditanifitinsls ol

P epanng rewdl sendom “Wirdow3' (3ol 3)
Updatng e dupley

This study was carried out to find the best combination of parameters that will be
taking into account on the final optimization study.

The conclusions we have are:
For minimum VM Stress, we need the following:
-Maximum Thickness

-Maximum Cut length
-Minimum Cut Radius



6.4 The Optimization Study on Total Mass

File>New Optimization Design Study

Analyses and Design Studies g
File Edit Run Info
New Static...
|
.} New Modal...
i New Buckling...
New Fatigue... *L | Status
ity Completed
New Prest »
SIS re.ss ty Completed
New Dynamic b Completed

New Standard Design Study...
New Sensitivity Design Study...
| New Optimization Design Study... |

Close
e ————————————————————————————————————

[- Description




Fill out the blank spaces, click on create and type the right value for the maximum
allowed stress, modify the rest of the values if it is necessary (we are going to use 10
iteration to save time, but the minimum suggested is 15)

i N
() Optimization Study Definition u
Name
!study‘l !
Description
Type
| Optimization '|
Minimize v || total_mass
( [t ) (]!}
|
— Design Limits
Measure Value Units o
— mm]
max_stress_vm =< [24000 l Ibom/(ins..
ooty
(mm]
Analysis Loadset
notch_plate_static || Name Component
LoadSet1 PLATE
Variables
Variable Current Minimum Initial Maximum Units ‘ m ’
cut_length 6 4 6 8 in =
| : . =t
cut_radius 0.25 0.1 0.25 05 in ‘
e —— jm=]
thickness 0.25 0.135 0.25 0.375 in = ‘

I Options...

| OK I [Cancel]




Run the design study, it will take several minutes.

Analyses and Design Studies u

File Edit Run Info

- ’——_ —
7 B X A =
Analyses and DesigeStudia
Start run
Name ———1y pE Status
Z Global Global Sensitivity Completed
| Opt_Study Optimization Not Started
v local Local Sensitivity Completed
/ notch_plate_static  Standard/Static Completed

— Description

|




Check the status file and compare it to the shown below.

The final values:

Run Status (Opt_Study.rpt) Not Running

Summary [Log ' Checkpoints '

[Begin Optimization Iteration 7 {(16:30:14) -
Converged to optimum design.

Best Design Found:
Parameters:

thickness 8.135
cut_radius 8.5
cut_length 4

Goal: 9.0868e-61

‘Optimization study statistics:
|Number of Base Analyses: 7
Number of Perturbation Analyses: 4

Memory and Disk Usage:

Machine Type: Windows XP 64 Bit Edition
RAM Allocation for Solver (megabytes): 128.8

Total Elapsed Time {seconds): 71.080

Total CPU Time (seconds): 8.16

Maximum Memory Usage {(kilobytes): 234405

Working Directory Disk Usage (kilobytes): 26

Total Elapsed Time in Parameter Updates {seconds):
21.32 |2

Total Engine Elapsed Time Minus Param. Updates {seconds):
49 .68

Total CPU Time in Parameter Updates {seconds):
8.86




Now, we are going to find the values to minimize the Von Mises Stress

Edit the design Study, and change the study from mass to max_stress_vm (goal)

Analyses and Design Studies t

File Edit Run Info

/ B X ’\ﬁ‘ﬂl

Analyses and Design Studies

Name Type Status
7 Global Global Sensitivity Completed
7 Opt £ : . 'iation Completed
Z local | Edit. | ensitivity Completed
 notch Copy rdiStatic Completed
Delete
Start
Stop
r Descriptio ]
= Status...

Optimization Study Definiton W% —
Name ul
\Opt_smcy ’
Description
|
Type
| Optimization 'I
Goal
A
| Minimize (max_stress_vm ) | (2
e Loadset
'ﬁC:E':'h-rr-"'33’9_'3‘153‘[[ ‘ Hame Component
LoadSetd PLATE
\



Click OK and run the study

The final values to get the Minimum Von Mises Stress

‘Converged to optimum design.

fBest Design Found:
| Parameters:

thickness 8.375
cut_radius 8.108579
cut_length 4

Goal: 7.6672e+03

gﬂptimization study statistics:
{Number of Base Analyses: 7
'Number of Perturbation Analyses: 22

>
Run Status (Opt_Study.rpt) Not Running ’_z:g_
Summary |Log (Checi(;oints "
Result of Optimization Iteration 6
Parameters:
thickness 8.375
cut_radius 8.1088579
cut_length 4
Goal: 7.6672e+03
Status of Optimization Limits:
1. max_stress_um 7.6672e+83 < 2.40008e+84 (satisfied withir
Resource Check (16:40:44)
Elapsed Time {sec): 65.75
CPU Time {sec): 9.27
Memory Usage {kb): 236517
Wrk Dir Dsk Usage {kb): 26
'Begin Optimization Iteration 7 (16:408:44)




